Welcome to Yserbius.Org! Join our Ultima Online Private Server and have some old school fun.

Trouble Getting Vitamin F to Work


Message for Upgrade

I have spent the last couple hours trying to get Vitamin F to work, and I've finally given up and decided to ask around.

I tried loading Vitamin F before Yserbius.exe using a batch file, but everytime I would click "Play" on the character select screen, it would drop back to DOS with an error message saying I didn't have enough memory available (I needed 512k... lol). So I went and downloaded Dosbox v.63, and proceeded to mount my yserbius folder to the c: drive. I ran Vitamin F first, and then Yserbius. Low and behold... It worked (well there wasn't any sound) but the game loaded fine.

Here's where I'm at now. While in game, I hit F12 to "search for my character". A message pops up that says "No luck...". So I go into the dungeon and then return to town and hit F12 again. This time it says "Character found", then pauses for a sec, then says "Autoheal on" and "Automana on". Yippee I think to myself. But then I go into the dungeon and fight some enemies. Hmmm, no autohealing and no automana. So I try ctrl-F12 to set my stats. It says "Enter the first letter of the stat:" so I type 9 (to set all my stats high) and then hit enter. I get excited again, but only until I go to the stats screen and find that none of my stats have changed. After hours of testing, I can't get ONE SINGLE feature of Vitamin F to work, either in the dungeon or the town, aside from the fact that it prints text to the screen.

Anyone have any ideas?

If it matters at all I'm running XP Professional SP2, Yserbius 1.0, and Vitamin F release 4.


Inactive Members
Here's what I do...
Start>> run>> type "cmd" in box>> <enter>
That'll take you into dos...
Run vitaminf from it's directory... (I don't have Yserb and VitF in the same directory)
Then run yserbius (while in dosbox)
Enter yserbius volcano, F12 to find character...
Have fun!
Everytime ya leave an return to the 'cano ya must find your character again!

Control F12 - Stats
Can set any of the 16 stats on the stat screen. It will ask which one you want to change. Enter the first letter of the stat you want to change, unless it is dex, then use x. To change the right side of a stat, enter in a second letter as well. It doesn't matter what the second letter is. After you press enter it will ask you for the value you want to set it to.
So to set your defense to 22, type d and press enter, then type 22 and press enter. To set your maximum mana (right side) to 25000, type mm and press enter, then 25000 and press enter.
Only use lower case letters. Stat 9 changes both sides of your attributes to high values. Stat 8 changes the plus side to high values.
Link to "Vitamin F Manual (better version)"...

I never tried to get the sound working. Check out this link...
It works! Both sound and Music and I'm running Windows XP.
Ok I downloaded VDMSound and installed it on my computer. I tried to run Yserbius using VDMS without making the LSCI.cfg file but no sound or music still. So I reconfigured my directories to make a parent directory similar to your setup Slohand of C:/program files/INN and placed Yserbius into this directory. I created the LSCI.cfg file in the C:/program files/INN using notepad. Ran the Yserbius.exe file using VDMS and boom! I had sound and music! Works great too! Thanks bro!
Hope that helped :)


Message for Upgrade
Well I've gotten sound to work using VDMSound, I just figured that Dosbox would provide the same functionality. My primary goal right now is just to get Vitamin F working once, so that I can change my stats and then return to using VDMSound instead of Dosbox.

I'm not sure I understand what you said to do. I am supposed to open up a command prompt, run Vitamin F, and then open up an instance of Dosbox and run Yserbius from there? I tried that and it didn't work. I'm pretty sure that this would make Vitamin F and Yserbius run in two separate memory spaces, right?


Inactive Members
I run both VitF (start first) and Yserb in the same "cmd" dos window (Win XP). I don't use VDMsound, a batch file or Dosbox v.63.
My ways not the best or quickest to start it up, but it works :D


Inactive Members
I'm sorry, I've followed this post to the letter, and I cannot get anything to work. I cannot create items, I cannot alter stats, particularly my experience, which is what I want to do. I assume that the stat letter for Experience is "e" but it doesn't seem to want to work.